the Dune Buggy Archives
DBA Forum - Not logged in
Previous Next Up Topic Public / General Discussion / fuel gauge not working (2628 hits)
By Chuck S 4680 Date 2016-09-01 21:56
Just picked up a buggy with fiberglass body, Being a pain and without taking the hood off and looking to see how the gas sensor gauge might be put in the tank, have a filler cap in center in hood, I'm trying to get my vw  gas gage in the speedometer on the dash to work. When turning the key on the gas needle fluctuates  to full then drops then back up again, then repeats. Any ideas what wrong with the gage.
By Jeffrey P 655 Date 2016-09-01 22:23
Could be the sending unit. The tank should be grounded. Or the vibrator at the back of the gauge could be faulty.
By Chuck S 4680 Date 2016-09-01 23:02
I think I will try the vibrator on the back, Just how are some of these sending units installed in a buggy , since  I cant see mine under the  fiberglass hood. Thanks
By Jeffrey P 655 Date 2016-09-02 02:52
Its like 5 or 6 pan head screws in a circle that hold the sending unit onto the tank.
By bob P 3255 Date 2016-09-08 22:02
Make sure that if you install a new sender or re-install  your old one, that you use a good seal as they have a tendency to leak gas around the sender where it mounts to the tank. Also, don't tighten it too tight or the rubber seal that comes with the sender will eventually harden and then crack and then you have to do it all over again. This comes from 48 years of dune buggying.
By Chuck S 4680 Date 2016-09-19 23:58
found the problem. The sending unit was good, replaced the gauge vibrator unit and now gas gauge is working great, thanks
Previous Next Up Topic Public / General Discussion / fuel gauge not working (2628 hits)

Powered by mwForum 2.10.2 © 1999-2007 Markus Wichitill