the Dune Buggy Archives
DBA Forum - Not logged in
Previous Next Up Topic Public / General Discussion / Allison starting issues (2363 hits)
By Jamie Appling Date 2014-02-01 15:32
I have a crazy buggy question. My Allison has a push button start I flip a switch and push a button to crank the engine. I can crank the engine get it turn over and start when it is cold. But after driving it for an hour or more I can turn the engine off and if I don't crank it right back up and let it sit for a little while it will not turn over when I push the button. The dash lights come on when I flip the switch and they dim when I push the button but won't turn the engine over. I can hook it to a booster or another car and it will turn right over and start. I can push start it with no problem.

Has anyone ever heard of this in any of your buggies or other cars before?
By Brad H 1498 Date 2014-02-01 15:50
Start by checing all your battery cable conections and makes sure they are good and clean tight. Get your battery and starter checked after if you still have a problem. If corroded cables or ends aren't your problem the starter or battery might be going away. Also there is a bushing in the transmission that the starter drive rides in. Remove the starter and see if it is oblong if it is the starter drive isn't supported and will drag when the engine is hot and has the most resistance. Replace the bushing just for good measure while your in there. You can run a 10mm tap into it, thread a bolt in and use that to pull it out.

brad
By Jeffrey P 655 Date 2014-02-01 15:59
If you do decide to replace your starter consider upgrading to an autostick version. There is no bushing to worry about, they are heavier duty, and the nose is self supporting so they are easier to test.

Autozone (or Advanced Auto...can't remember which) carry nice ones for cheap money with a lifetime warranty.
Previous Next Up Topic Public / General Discussion / Allison starting issues (2363 hits)

Powered by mwForum 2.10.2 © 1999-2007 Markus Wichitill