the Dune Buggy Archives
DBA Forum - Not logged in
Previous Next Up Topic Engines / Subbug - Subaru Power / EJ20TT engine won't fire, help?? (16469 hits)
By Tom V 842 Date 2009-09-06 17:47
When I tried the engine after modifying the loom, it starts up first go but stops after about 15 seconds because the ECU isn't powering the fuel pump relay.

When I power the fuel pump directly instead of letting the ECU do it, no change.

Next few times I try to start it up the spark plugs are soaking wet in fuel, when I clean them the engine will start up a few times but same story as before.

Then when cranking, a small puff of smoke comes up from the engine around the knock sensor area and there's a smell of something burned, really have no idea what it was and can't find any visible evidence of a burned part.

After that happened the spark plugs do not fire when I test them separately outside of the engine when cranking.

Any EJ20R guru's out there that might have an idea?

I'm trying to get hold of new crank and cam sensors and also new coils but it's not easy since I live in Belgium.

I think the coil packs are working correctly and when the ignition is on, the yellow wire on each one get a current but no park when cranking.

Could a broken crank sensor cause this? I'd imagine if only the cam sensor was broken it would start up but run rough.
Sorry for the long post but I really don't know why it won't start up and I can't take it to a garage over here.

The engine is in a Bug by the way, I have posted here before but was a long time ago

http://www.cardomain.com/ride/844382#guestbook
By Jay H (X-20) (ManxVair CC) Date 2009-09-06 22:19
A bad crank position sensor won't read RPM which is what the ECU needs to send power to the fuel pump (I believe).

Now sure what your puff of smoke was. Hopefully not a coil pack. they can be pricey to replace with new ones.

You say after modifying the loom. Did it run before? If it ran good before, see if you can tell if you may have crossed some wires when modifying the loom or something?

Jay
By Tom V 842 Date 2009-09-07 11:45
So bad crank sensor might be the cause for the fuel pump not being powered, that sound reasonable.

About the coil packs, if one were to be bad after I saw the smoke it should be the one nearest to the smoke. I've measured resistance on the coil packs with a multimeter and the are all 4 exactly the same so I can assume they all still work.

I haven't ran the engine with this loom before modding it but the engine ran (although boost was on and off but that's because the vacuum lines weren't hooked up properly) with the old loom before.
By Tom V 842 Date 2009-09-15 15:30
Ok, so I replaced crank and cam sensors with new ones and still no spark :-(  :-( :-(

I have 2 3 plug ECU's with a full loom each to try and no spark with both.

What does happen with 1 loom though, when I stop cranking the engine the nearest cylinder on the front left side of the engine sparks 1 time and that's it, very, very weird.

Any ideas?

I cleaned the air flow meter with brake cleaner but no difference.

I alo tried different coil packs but seeing as they don't even get a signal, no change.
By Jay H (X-20) (ManxVair CC) Date 2009-09-15 21:57
Hmmm, I wonder if you need to swap the leads on the crank sensor around. I recall the VR sensor needing the correct polarity in order for the ECU to convert the sign wave to a square wave needed to control the coil packs..... Wondering if when you shut the engine down either the RPM is so slow, that the collapsing sign wave will fire the coil pack once as you described... or possibly the engine turns slightly in the backward direction when coming to a stop?

I wish I was smarter with this stuff, but truth be told, Paul is "the guy" when it comes to stuff like this.

Jay
By Tom V 842 Date 2009-09-16 12:00
I just replaced the entire engine loom with a spare one I bought.

Result, still no spark. Not even the weird single spark I had before.

The ECU isn't giving out any signal to any coil when cranking the engine.

Would a faulty air flow meter cause the engine not to spark?
By Tom V 842 Date 2009-09-22 18:44
Seems the new crank sensor was sending a signal to the ECU it couldn't understand. Swapped it for anouther crank sensor (a brown one like I originally had) and now it fires.

Starting it when cold is still difficult, when I use some starter pilot it starts up with a few cranks and runs perfectly for a few minutes before overfueling -> spark plugs get black and can't spark any more.

Then when I clean the spark plugs it does the same thing.

I've dropped off the injectors to get cleaned and tested. If that doesn't solve the overfueling it might be bad cam sensor, broke ECU or faulty cold start.
By Jay H (X-20) (ManxVair CC) Date 2009-09-22 20:28
Ive seen bad ECU's from people swapping the wrong resistance injectors before. I wonder if that is what you have there. Do you have someone with a stock ECU to swap out for troubleshooting?

Sounds like the ECU is OK in the closed loop mode until it opens up, then in the open loop mode, it's over-fueling.

Jay
By Paul Moran (DBA Architect) Date 2009-09-24 03:39
Hi Tom - I took a quick read through this and there could be a number of causes for this.  The bug looks awesome BTW.

First question - if your not getting spark, is the ECU "seeing the engine" turn?  What's the ECU?  How do you know the ECU sees RPM?  Does the fuel pump turn on and stay on? 

On fouling out plugs, how much return fuel to you have going back to the gas tank? I had a stuck fuel pressure regulator which will cause the fuel rail to hold about 90 psi of pressure depending on the pump. This will cause way too much fuel to dump in. 

Is the ECU seeing the right engine temp?  If the temp sensor is broken, it will keep the mixture rich thinking that the engine is still warming up.

You could have one or more injectors leaking into the cylinder. 

I'll try to keep an eye on your topic here and get back to you quickly as you post.  Give me a call at 630-492-0809. I'm in Chicago, so please keep an eye on the time zones... We could also set up a time on Skype to avoid the international phone charges.

Good luck and lets get this thing running!
Paul...
Chicago, IL
EMPI Imp 1002 ('69)/Subaru EJ20 Turbo/LinkPlus ECU
By Tom V 842 Date 2009-09-26 19:42
I replaced the "O" rings on the injectors (one was vissibly damaged) and that seams to have cured the overfueling.

Also put in new platinum spark plugs.

I've got it to start up now a few times (have to recharge the battery a lot with all this cranking) and is runs very smooth and coolant temp. rises as it should but once it reaches somewhere between 135 and 150 Fahrenheit it stops idling and dies.

Most times I can't get it to fire up, not even with starter pilot (simply no spark).

The crank and cam sensors both give signals to the ECU (stock 4G 3 plug ECU by the way) so that's not the problem anymore.

I've got an aftermarket temp gauge split into the water temp sensor (the small, left hand side one behide the alternator) and that looks like its giving a correct reading.
By Jay H (X-20) (ManxVair CC) Date 2009-09-27 06:01
Coolant temp is the sensor that "flips the switch" in the ECU to go from closed loop mode (where the ECU provides it's own parameters for the fuel map... and during warm up is always rich) to open loop, (where the ECU figures the fuel map based on all the parameters it receives from all the other sensors).

I recall Paul saying he had to have some resistors and things like that to fool the ECU into thinking it was getting a signal from some missing sensors.

I'm wondering if you are in a similar boat at this point. I would do a check with the sensors I had against the stock wiring harness to see what the stock system is looking for that I didn't have just to be sure that a missing sensor wasn't the issue.

Jay
By Tom V 842 Date 2009-10-02 18:19
It finally runs good now but doesn't want to idle when warm. It needs a new water temp. sender for the ECU and a new IACV.

http://www.youtube.com/watch?v=0XH4vFT4AX8

Hopefullly will be able to finish up suspension, gears, clutch and gas cable + lots of other bits that need tidying op over the next week or so and then take it for a test drive 
By Tom V 842 Date 2009-10-06 17:33
Managed to get the CEL light working (the pinout on the ECU is the negative side of the light bulb and not the positive like I thought).

Ran the engine and after that got code 23 (Air Flow Sensor) and code 12 Starter Switch).

I changed out the MAF and it made a big difference, when cold it started up way better ( no throttle needed at all).

It still doesn't want to idle when warm and dies when I don't give it throttle.

I disconnected the battery now and am hoping that when the ECU is reset this will cure the engine not idling when warm(is this possible?).

As for code 12, I have no idea how to fix that since I have the engine in a VW Bug. Is it even worth it to try to fix this as I can't imagine what would be the result of the ECU throwing this code.
Previous Next Up Topic Engines / Subbug - Subaru Power / EJ20TT engine won't fire, help?? (16469 hits)

Powered by mwForum 2.10.2 © 1999-2007 Markus Wichitill