the Dune Buggy Archives
DBA Forum - Not logged in
Previous Next Up Topic Engines / Subbug - Subaru Power / Prep for test firing ej20g motor (6650 hits)
By Bryan G 3191 Date 2012-04-25 15:52
Hi all,
I have been lurking here from time to time as i gather the parts and courage to install my suby ej20g motor in my '69 baja bug. This is my first foray into EFI and turbo so I am hoping for some pointers from those who have been there - done that.
Anyway, the motor has been sitting on the stand for several years and I am getting ready to mount it to my 091 transaxle and test fire it. I have an EMS Stinger v4 ecu, igniter, and harness.

One of my first needs is to get a good base map loaded into this ecu. If anyone has a good map for this engine that they would be willing to email me, I would be most appreciative!

I am also looking for any tips on pitfalls that I should avoid in firing up this motor. Example: I am concerned about firing up a 'dry' turbo. Should I maybe get oil pumping to it by cranking the motor some with the igniter disconnected?? Any and all tips welcome here.

Note that I plan on test firing the motor without any coolant. I have been told this is not a problem as long as it is not ran for more than a few minutes.

Thanks in advance for any help provided.
By Sandsurfer Date 2012-04-28 20:09
The turbo will be fine, it doesn't spin very fast at idle and should get oil pressure almost instantly, once the engine fires up.. You can always pull the feed line from the top of the turbo and squirt some oil directly into the turbo. 
Jerry....
By Bryan G 3191 Date 2012-04-29 12:53
Thanks Jerry,

I plan on cranking the engine for a few seconds without spark to get oil flowing a bit. Easy enough.

The real fun happening now is trying to make sense of all the wire harness connections and 'mystery' fittings on the engine. For example, how do I know which injector connector goes to which injector? Forgive me if this question exposes my EFI ignorance! There are #'s stamped on the case that I believe are the cylinder #'s, but the wiring is not labeled. The EMS Stinger manual does show coil #'s which correspond to a pin # on the main connector. I assume these should connect to their matching cylinder as stamped on the case..

Thanks again. I will be working on getting this baby temporarily wired and plumbed up for test firing very soon. That will be a huge milestone in this prolonged project for sure.

Bryan
By Tom & Kathleen I 639 Date 2012-04-29 21:53
I think the injectors are batch fire so it doesn't matter which is hooked up.  I also beleive those are cylinder #'s marked on the case.  If you have electrical questions, call Outfront and ask for Lance, he is the wiring guy, very helpfull.  We just had a wire pull out of the connector that plugs into the computer, they sent us a tool to borrow to fix it and some connectors.  I have returned the tool, and bought my own, now that I know what is looks like.   Tom
Tom & Kathleen Manxter #16, Kick-Out SS #16 & FiberFab Buggy
Manx Club #1030, CVA, RBC, SCCA
By Bryan G 3191 Date 2012-04-30 19:37
Thanks....I was thinking that was the case (batch firing).
My next tasks at hand are:
- get the wiring harness fully documented, labeled and checked for continuity
- get decent base map loaded onto my EMS Stinger 4424v4 ecu (help ??)
- install adaptor plate, flywheel, and clutch assy
- mount engine to transaxle
- temporarily wire for test run
- temporarily plumb fuel pump for test run

Is it OK to test run motor without alternator?
By Tom & Kathleen I 639 Date 2012-04-30 22:04
The EMS Stinger website has maps.  http://www.enginemanagement.com.au/maps.php Otherwise, I would call John at Outfront and see if he can send you one.  Tom
Tom & Kathleen Manxter #16, Kick-Out SS #16 & FiberFab Buggy
Manx Club #1030, CVA, RBC, SCCA
Previous Next Up Topic Engines / Subbug - Subaru Power / Prep for test firing ej20g motor (6650 hits)

Powered by mwForum 2.10.2 © 1999-2007 Markus Wichitill